eclipse: The Eclipse executable launcher is configured to not start with administrative privileges

作者: wxfeng 分类: 杂项 发布时间: 2018-11-19 00:00

问题描述:在fedora 26系统中,以root用户使用eclipse。

在启动eclipse时弹出错误:

The Eclipse executable launcher is configured to not start with administrative privileges

解决方法:这都是因为Eclipse运行时选项:

-protect 
root

将值设置为“root”可防止Eclipse以root用户身份启动,直接或通过以“sudo”等管理权限运行的程序启动。此选项目前仅在基于Linux / UNIX的平台上实现。

关闭它,Eclipse便可正常启动。

要将其关闭,从eclipse.ini文件中删除包含此选项的两行代码即可。

配置文件位置:/etc/eclipse.ini


如果觉得我的文章对您有用,请随意赞赏。您的支持将鼓励我继续创作!

发表评论

电子邮件地址不会被公开。 必填项已用*标注